• Welcome to the all-new Kolakube support, the official place to get help for Marketers Delight, XFtoWP, CryptoWP, and other WordPress products! Please login with your account details to access members-only support forums.

User Logged into XF, but does not Auto-Login to WP.

DDyack

Active member
XFtoWP
Messages
34
Reaction score
5
Our users, when logged into XF Forum and then go to visit the WP store aren't automatically being logged in to WP. I've verified that the user was sync'd between the two systems and the settings we are using are below. I've also created a test account to double check and it's doing the same thing. What am I doing wrong in the setup?

1686069200605.png
1686069492451.png

Second question: Are there any conflicts or limitations to using Simple Turnstile Cloudlfare plugin with the bridge? It's similar to Google's Recaptcha, but doesn't seem to work as a current user (new registrations work fine). Just curious if you've heard of anything before.
 
Solution
Excellent, thank you for the feedback. Caching and CDNs tend be this plugin's greatest enemy but I'm glad you found a workaround here.

I will release this addon to the XF resources directory so others can use it, as it works great in my testing too.

Edit: The Login users to WordPress addon is now available for download. Also refer to this post for a fix to possible Recaptcha issues (if applicable).
Hi @DDyack!

Our users, when logged into XF Forum and then go to visit the WP store aren't automatically being logged in to WP. I've verified that the user was sync'd between the two systems and the settings we are using are below. I've also created a test account to double check and it's doing the same thing. What am I doing wrong in the setup?
Capturing a user login from XF is not part of the plugin, as only actions made from WP are able to use the sync features.

Fortunately I have an unreleased addon for XenForo adds this exact capability to your site. If you are hosting both sites on the same server with a readable file path (not a restriction of the XFtoWP plugin) the Login addon should work. It's a simple addon and I can send it to you to test if you'd like.

Second question: Are there any conflicts or limitations to using Simple Turnstile Cloudlfare plugin with the bridge? It's similar to Google's Recaptcha, but doesn't seem to work as a current user (new registrations work fine). Just curious if you've heard of anything before.
User syncing actions only happen after registration from WP, so there shouldn't be any conflicts.
 
Comment
@ScarletCox @DDyack great, I have messaged you both.

The only requirement is the WP and XF site cannot be subdomains. So the sites have be located at domain.com and domain.com/forums/ or vice-versa so each installation can read the others files.
 
Comment
The only requirement is the WP and XF site cannot be subdomains. So the sites have be located at domain.com and domain.com/forums/ or vice-versa so each installation can read the others files.

Ah, that's me out, then! I have domain.com and forums.domain.com haha.
 
Comment
Ah, that's me out, then! I have domain.com and forums.domain.com haha.
Sorry to hear! That is the limitation I have found when I have had XenForo addons developed, which is not the case in XFtoWP which uses the REST API and can travel across any domain configuration.
 
Comment
@Alex, I followed the instructions in PM and tested it with a regular user account (non-admin) by logging into the forums first, clicking a link to go to the Wordpress store, adding an item to the cart, and it's asking for me to log in again.

Both XF and WP are on the same server. The WP is in the root and XF forums are under /forum. Pulled the WP directory location and added it to the XF Addon.

Is there anything else I could try?
 
Comment
@Alex, I followed the instructions in PM and tested it with a regular user account (non-admin) by logging into the forums first, clicking a link to go to the Wordpress store, adding an item to the cart, and it's asking for me to log in again.

Both XF and WP are on the same server. The WP is in the root and XF forums are under /forum. Pulled the WP directory location and added it to the XF Addon.

Is there anything else I could try?
It sounds like you have the configuration correct. Do the users have the same password?
 
Comment
It sounds like you have the configuration correct. Do the users have the same password?
I figured it out and thought I'd share it here in case someone else has the same issue.

We have WordFence installed and within it we are using ReCaptcha which was causing WP to send an email to the user to verify the login so the XF Bridge never had a chance to connect the accounts together, in a sense, because we had to jump through the Recaptcha email hoop first. Since we have Cloudflare's turnstile handling the recaptcha part now, the WF Recaptcha has been disabled and that fixed it.

Thank you for the help on this! Very cool it works both ways now. :)
 
Comment
Excellent, thank you for the feedback. Caching and CDNs tend be this plugin's greatest enemy but I'm glad you found a workaround here.

I will release this addon to the XF resources directory so others can use it, as it works great in my testing too.

Edit: The Login users to WordPress addon is now available for download. Also refer to this post for a fix to possible Recaptcha issues (if applicable).
 
Comment
Solution
Back
Top