Resolved Questions

Razvan

Member
XFtoWP
Messages
8
Reaction score
2
Hello, I just purchased the plugin and did the connection, apparently is working, but I registered using WP and then I tried to log in with the same user on Xenforo but the user couldn't be found, why is that? Aren't the users supposed to sync? [EDITED]

Especially with the API user permissions, they are showing that nothing is selected even though they are actually checked in Xenforo -> [EDITED]

How is the plugin working?

I have watched this but I don't see user sync nor user groups

Maybe I did something wrong but the connection is happening as you can see in the screenshot but I'm not seeing the options that you do, so what should I do now?
 
Last edited by a moderator:

Alex

MD developer
Staff member
Md
XFtoWP
Messages
6,276
Reaction score
1,694
Hey @Razvan, thank you for purchasing XFtoWP! A couple of questions:

1) does your forum return a json page when you go to https://domain.com/api/?

2) did you create a user key or super user? I can't tell the type from the screenshot

3) if you made a super user key, make sure the right user ID is entered into the XFtoWP API settings
 
Comment

Razvan

Member
XFtoWP
Messages
8
Reaction score
2
Hey @Razvan, thank you for purchasing XFtoWP! A couple of questions:

1) does your forum return a json page when you go to https://domain.com/api/?

2) did you create a user key or super user? I can't tell the type from the screenshot

3) if you made a super user key, make sure the right user ID is entered into the XFtoWP API settings
1. [EDITED] this is what I receive
2. I created a user key and a super user key, they are both doing the same thing
3. Yes, it's the right user ID -> [EDITED]
4. But why am I not seeing the usergroups tab and the user sync?
 
Last edited by a moderator:
Comment

Razvan

Member
XFtoWP
Messages
8
Reaction score
2
I'm not trying to be a pain in the ass or rude but my community is waiting for this connection to happen since 2 days ago, I understand that you may be busy but I bought this plugin in order for everything to work and now you're not even answering, I have everything on hold and still waiting for an answer @Alex
 
Comment

Ray

Well-known member
Staff member
Md
Messages
430
Reaction score
213
Location
Los Angeles
I'm not trying to be a pain in the ass or rude but my community is waiting for this connection to happen since 2 days ago, I understand that you may be busy but I bought this plugin in order for everything to work and now you're not even answering, I have everything on hold and still waiting for an answer @Alex
Sorry for the wait @Razvan, I'll reach out to Alex immediately. Thank you for your patients.
 
Comment

Alex

MD developer
Staff member
Md
XFtoWP
Messages
6,276
Reaction score
1,694
@Razvan Are you sure the XenForo API key is correct? It looks short in your admin settings screenshot.
 
Comment

Alex

MD developer
Staff member
Md
XFtoWP
Messages
6,276
Reaction score
1,694
Thank you, I logged in and after clicking "Refresh forum data" your forum info successfully showed up in the admin area. When in doubt, and when you make changes to your API user from XenForo, use this button to refresh forum data.

You can now finish the setup process, including access to the Usergroups and User sync settings.

Screen Shot 2021-09-07 at 4.52.42 PM.png
 
Comment

Razvan

Member
XFtoWP
Messages
8
Reaction score
2
Thank you, I logged in and after clicking "Refresh forum data" your forum info successfully showed up in the admin area. When in doubt, and when you make changes to your API user from XenForo, use this button to refresh forum data.

You can now finish the setup process, including access to the Usergroups and User sync settings.

View attachment 3562
Awesome, thank you!
 
Comment
Top