Resolved Connected Plugin to Staging Site, API will Not Connect User Permissions

donniewalden

Member
XFtoWP
Messages
6
Reaction score
1
I saw a user with the same issue on a different thread, but the solution didn't work for us. I've tried turning all of our plugins off and just getting the API to connect. I'm not receiving any error messages either, just not getting the API User permissions hooked up.

I am using the Super User ID 1 from my admin on our Xenforo build which is an a different domain than our website. I have the correct API key and Xenforo key. I am also running it on a staging site as a subdomain, and have that domain plugged into the XFtoWP site for activation.

It seems like I've followed every step correctly, have the green check mark up on the Site Settings, but can't get those other connections to come through. Can you give me any ideas? :)

Thank you! Looking forward to getting this into action.
 
Last edited by a moderator:
Solution
Hey @Alex - I've turned on friendly URL's.
I've been assured on server side the /api folder does not exist in the Xenforo root.
Still no connection being made. Correct keys and license is valid. But ya' you're right about the page not returning for the URL /api.
Any other ideas we could try?
Try adding the following to your src/config.php file as cited from the XF docs:

$config['enableApi'] = true;

Alex

MD developer
Staff member
Md
XFtoWP
Messages
6,271
Reaction score
1,693
Hi @donniewalden, thanks for posting here!

I assume you are referring to this thread, and at first glance it seems to be the same problem: your forum API isn't returning a response.


Do you have the Friendly URLs setting enabled in your XF admin? I notice your forum URLs still have index.php in them, and may be causing the API to be read incorrectly.
 
Comment

donniewalden

Member
XFtoWP
Messages
6
Reaction score
1
Hey @Alex - I've turned on friendly URL's.
I've been assured on server side the /api folder does not exist in the Xenforo root.
Still no connection being made. Correct keys and license is valid. But ya' you're right about the page not returning for the URL /api.
Any other ideas we could try?
 
Comment

Alex

MD developer
Staff member
Md
XFtoWP
Messages
6,271
Reaction score
1,693
Hey @Alex - I've turned on friendly URL's.
I've been assured on server side the /api folder does not exist in the Xenforo root.
Still no connection being made. Correct keys and license is valid. But ya' you're right about the page not returning for the URL /api.
Any other ideas we could try?
Try adding the following to your src/config.php file as cited from the XF docs:

$config['enableApi'] = true;
 
Comment
Solution

donniewalden

Member
XFtoWP
Messages
6
Reaction score
1
Hey @Alex - this change got it working! Thank you so much!

On a side note, can you point me in the direction for how to bulk sync users from Wordpress?
I have roughly 11k users I need to sync to xenforo and would love to use this plugin to do it, just can't seem to find anywhere to sync all at one time. Is that an option?
 
Comment
Top