• Welcome to the all-new Kolakube support, the official place to get help for Marketers Delight, XFtoWP, CryptoWP, and other WordPress products! Please login with your account details to access private support forums.
  • Support reminder: Please do not use private messaging for product support. Post questions to the respective forums to get help.

Book Shortcode

Richard Brown

Active member
Md
Messages
84
Reaction score
11
Alex, I am trying to post the top five books I read this year. I want to use the shortcode to show the books how it the Stream works.

I used this shortcode in a post, and nothing was visible.

[book id=”907″ type=”excerpt”]

Did I miss a step? Is there another way to do this?
 
Solution
Hi @Richard Brown, this sounds crazy, but I think the shortcode is being broken in your editor as a format issue.

When I copied the shortcode from your original post, it pasted the quotes and commas as unrecognizable text in the post editor. When I manually typed out my shortcode with book IDs, it worked as expected:

Screen Shot 2022-01-23 at 6.04.05 PM.png

Can you give that a try and let me know how it works?

Alex

MD developer
Staff member
Md
XFtoWP
Messages
6,489
Reaction score
1,820
Hey @Richard Brown, apologies for the late reply! I am recovering from an illness from over the holidays.

The only thing I can think here is if the Book ID is correct? To confirm, are you posting the shortcode in the post editor? If using the Block Editor make sure you paste it into a "Shortcode" block.
 
Comment

Richard Brown

Active member
Md
Messages
84
Reaction score
11
@Alex I checked and tested it, and no bookshelf excerpt. It works on the bookshelf, and when I include a book in a post, I add the post number.

This may be part of a bigger problem. I no longer get comment notifications when I do internal links. Very strange.
 
Comment

Richard Brown

Active member
Md
Messages
84
Reaction score
11
@Alex I thought it might have been caused by th cache program. I made some changes and cleared the cache. I used this shortcake - [book id=”2094, 2030, 1878″ row=”3″] - in a new Stream. When I previwed it I get an error message. Not sure how to resolve this?
 

Attachments

  • Screen Shot 2022-01-12 at 12.39.10 PM.png
    Screen Shot 2022-01-12 at 12.39.10 PM.png
    1.1 MB · Views: 2
Comment

Alex

MD developer
Staff member
Md
XFtoWP
Messages
6,489
Reaction score
1,820
@Alex I thought it might have been caused by th cache program. I made some changes and cleared the cache. I used this shortcake - [book id=”2094, 2030, 1878″ row=”3″] - in a new Stream. When I previwed it I get an error message. Not sure how to resolve this?
Thanks, this extra information is helpful. I have been a little confused by what the issue may be but this narrows it down. I will take a closer look into it now and report back with what I find!
 
Comment

Alex

MD developer
Staff member
Md
XFtoWP
Messages
6,489
Reaction score
1,820
Hi Richard, still debugging the shortcode issue. It's a strange issue causing me to go deep into WP, believe it or not...

Keep in mind from the Stream you can also share individual Books by pasting the book ID into the Post ID settings in the Stream options.
 

Attachments

  • Screen Shot 2022-01-18 at 3.19.16 PM.png
    Screen Shot 2022-01-18 at 3.19.16 PM.png
    44.7 KB · Views: 0
Comment

Alex

MD developer
Staff member
Md
XFtoWP
Messages
6,489
Reaction score
1,820
Hi @Richard Brown, this sounds crazy, but I think the shortcode is being broken in your editor as a format issue.

When I copied the shortcode from your original post, it pasted the quotes and commas as unrecognizable text in the post editor. When I manually typed out my shortcode with book IDs, it worked as expected:

Screen Shot 2022-01-23 at 6.04.05 PM.png

Can you give that a try and let me know how it works?
 
Comment
Solution
Top