• Welcome to the all-new Kolakube support, the official place to get help for Marketers Delight, XFtoWP, CryptoWP, and other WordPress products! Please login with your account details to access private support forums.

Auto-Post Into Specific Forum

atminside

Active member
XFtoWP
Messages
25
Reaction score
4
Hello, is it possible to auto-post into a specific forum instead of the default? i.e. we set the plugin as below, but the thread did not auto-post on XF.

1642606902689.png
 

Alex

MD developer
Staff member
Md
XFtoWP
Messages
6,498
Reaction score
1,829
Have you turned on auto post in WP admin > XF > thread comments > enable auto post.

Since it is an aggressive feature I've disabled it by default.
 
Comment

Alex

MD developer
Staff member
Md
XFtoWP
Messages
6,498
Reaction score
1,829
I just tested this workflow which posted a new thread to the forum set on the post screen:

1) WP admin > XF > Thread comments > Set "Post to default forum" to "Forum 2"
2) Go to Posts > Add new > Post to XF > Set "Post to forum" to "Forum 1".
3) Saved post, then published
4) Thread successfully created in "Forum 1"

I should note that if you change the forum in the post editor, but don't save before hitting Publish, the new forum won't be set. Save the settings while still in draft mode and they will apply upon post publish.
 
Comment

atminside

Active member
XFtoWP
Messages
25
Reaction score
4
Save the settings while still in draft mode and they will apply upon post publish.
This is what we've been doing, but when publishing the "Post to Xenforo" box does not change and the thread does not create. We're still having to manually "Create Thread" at that point.

Edit: this is also the same for scheduled posts, not just manual publishing.
 
Comment

Alex

MD developer
Staff member
Md
XFtoWP
Messages
6,498
Reaction score
1,829
This is what we've been doing, but when publishing the "Post to Xenforo" box does not change and the thread does not create. We're still having to manually "Create Thread" at that point.
I see - the XF meta box does not change when posted from the WP Blocks editor until the page refreshes. If you view the page immediately after publish or just refresh the editor you should see the thread details attached to the post.

This is a UI tweak we can make so it is more seamless to use.
 
Comment

atminside

Active member
XFtoWP
Messages
25
Reaction score
4
Refreshing/viewing isn't changing anything after posting, and the thread isn't showing up in XF. I'm assuming I don't have to wait for the Refresh Time to tick past for this, correct?
 
Comment

Alex

MD developer
Staff member
Md
XFtoWP
Messages
6,498
Reaction score
1,829
I'm assuming I don't have to wait for the Refresh Time to tick past for this, correct?
Correct - refresh time is only for thread updates after connection and general data syncing routines.

Refreshing/viewing isn't changing anything after posting, and the thread isn't showing up in XF.
Hmm, let's look at the basics now:

1) Are you sure the Note ID you added in WP admin > XF > Forums is the correct Node ID?
2) The API user has permissions to post to this forum?
3) What version of the plugin are you running? I just released XFtoWP 1.4 Patch 1 last night that may make a difference here

Thank you for working through this, we'll figure out what's going wrong!
 
Comment

atminside

Active member
XFtoWP
Messages
25
Reaction score
4
1) Are you sure the Note ID you added in WP admin > XF > Forums is the correct Node ID?
2) The API user has permissions to post to this forum?
3) What version of the plugin are you running? I just released XFtoWP 1.4 Patch 1 last night that may make a difference here

1 - Correct, and this persists across more than one Node ID.
2 - Yes, it has permission to post to almost all forums, and if I press the Create Thread button the thread creates as expected.
3 - I was not running Patch 1 yet. I updated and am having the same results.
 
Comment

Alex

MD developer
Staff member
Md
XFtoWP
Messages
6,498
Reaction score
1,829
Ok, I have run every combination I could on multiple sites—even scheduled posts—and every time a thread is posted as expected to the correct forum.

Another idea... are you trying this with Posts or Pages? Auto-post is only designed for blog posts.

At this point I'd be willing to take a look at your WP admin to see what may be going wrong, if you're open to it.
 
Comment

Alex

MD developer
Staff member
Md
XFtoWP
Messages
6,498
Reaction score
1,829
Ok, I am going to publish a test post in a few minutes. I don't have access to your forum to delete the thread if it goes through, so you may have to clean it up if I succeed. :D

Edit: waiting to see your response in the other thread before I do just to make sure I don't do too much at once.
 
Comment

atminside

Active member
XFtoWP
Messages
25
Reaction score
4
Hey Alex, just installed the new update. I saw that the auto-post feature had some changes made. Is it possible with the new 1.4.2 update to auto-publish into a specific forum or only the default? Thanks!
 
Comment

Alex

MD developer
Staff member
Md
XFtoWP
Messages
6,498
Reaction score
1,829
Hey Alex, just installed the new update. I saw that the auto-post feature had some changes made. Is it possible with the new 1.4.2 update to auto-publish into a specific forum or only the default? Thanks!
Yes, you can read the changes to the workflow here:


Basically, you have the ability to post to the default forum you set in WP admin > XF > Thread comments > Create thread > Default forum and you can override that selection in the "Post to XenForo" meta box on the post editor.

Once you've filled out your custom settings in the post you can either create the thread now by pressing "Create thread" or simply save and publish the post to create the new thread when ready.
 
Comment

atminside

Active member
XFtoWP
Messages
25
Reaction score
4
OK, maybe I'm misunderstanding the new logic. If we want it to auto-publish into a specific forum, the box should look like this prior to pressing Publish, correct? Because there is no forum selection box for the "Auto-create thread" option.

1642606902689-png.3805
 
Comment

Alex

MD developer
Staff member
Md
XFtoWP
Messages
6,498
Reaction score
1,829
OK, maybe I'm misunderstanding the new logic. If we want it to auto-publish into a specific forum, the box should look like this prior to pressing Publish, correct? Because there is no forum selection box for the "Auto-create thread" option.

1642606902689-png.3805
Correct. The "auto create" text only shows when you have the setting enabled, and will use your default settings, no configuration needed.

To make changes on the fly, you will select the "create thread" setting as you've done in your screenshot and thosenwill be the settings that apply when you publish.
 
Comment
Top