• Welcome to the all-new Kolakube support, the official place to get help for Marketers Delight, XFtoWP, CryptoWP, and other WordPress products! Please login with your account details to access private support forums.

API user has no API permissions.

Roo

Member
XFtoWP
Messages
9
Reaction score
1
Hi, I configured this, but still getting the following.

Tried with https, http, www, without www, with /, without /.

All the same.

1665607761738.png
 

Roo

Member
XFtoWP
Messages
9
Reaction score
1
Are you able to access the api directory in your browser?

Example: https://domain.com/api

It should return the same response as the api for this site:

efff3ec0c42422b18567689d8ea67072.png

https://gyazo.com/efff3ec0c42422b18567689d8ea67072

Nothing showing in the console.
 
Comment

Alex

MD developer
Staff member
Md
XFtoWP
Messages
6,703
Reaction score
1,901
silly me, i didnt include the API name, I can see this:
1da722277678e3843df0de7be491a4d8.png

https://gyazo.com/1da722277678e3843df0de7be491a4d8
  1. Disable password protection if either site uses it
  2. Make sure the Board URL in XFtoWP matches your XF site's Board URL setting
  3. Ensure "Friendly URLs" setting is enabled in XenForo
  4. Make sure the API key user has the equivalent permissions on the forum. Example: If your API user is not an admin on your forum, go to XenForo admin > Groups & permissions > Administrators and apply the "Manage users and moderators" permission to the API user account.
 
Comment

Roo

Member
XFtoWP
Messages
9
Reaction score
1
  1. Disable password protection if either site uses it
  2. Make sure the Board URL in XFtoWP matches your XF site's Board URL setting
  3. Ensure "Friendly URLs" setting is enabled in XenForo
  4. Make sure the API key user has the equivalent permissions on the forum. Example: If your API user is not an admin on your forum, go to XenForo admin > Groups & permissions > Administrators and apply the "Manage users and moderators" permission to the API user account.
Ok, 2,3,4 are all set as per. I'm unsure about 1. the forum is open and viewable incognito so is wp.
 
Comment

Alex

MD developer
Staff member
Md
XFtoWP
Messages
6,703
Reaction score
1,901
@Roo Are you using a super user key from XF? If so, add the Api user ID into the WP plugin settings. It's very likely at this point that something is blocking user permissions from your XF forum.
 
Comment

Roo

Member
XFtoWP
Messages
9
Reaction score
1
@Roo Are you using a super user key from XF? If so, add the Api user ID into the WP plugin settings. It's very likely at this point that something is blocking user permissions from your XF forum.
yes I am, and yes the super user ID is entered. We use Ezoic and I don't know if this is causing the issue.
 
Comment

Alex

MD developer
Staff member
Md
XFtoWP
Messages
6,703
Reaction score
1,901
yes I am, and yes the super user ID is entered. We use Ezoic and I don't know if this is causing the issue.
There has been mention of Ezoic before which has caused some issues. I am unfamiliar with the service but if it can be disabled and the plugin can be tested again, that would help add some clarity to the issue.

Relevant results: https://kolakube.com/community/search/69/?q=Ezoic&o=date
 
Comment

Roo

Member
XFtoWP
Messages
9
Reaction score
1
Hi, none of the sites is password protected so that's not affecting it.

Ezoic was disabled and tested again, still not working.
 
Comment

Alex

MD developer
Staff member
Md
XFtoWP
Messages
6,703
Reaction score
1,901
Are you able to provide a wp admin to check? I can only think that something isn't configured with the api user correctly but can't tell what without more info at this point.
 
Comment

Alex

MD developer
Staff member
Md
XFtoWP
Messages
6,703
Reaction score
1,901
@Roo Untill I return fully back online, there is a test you can run that will print the api response message with a small coding trick. I will try to post those instructions shortly today.
 
  • Like
Reactions: Roo
Comment

Alex

MD developer
Staff member
Md
XFtoWP
Messages
6,703
Reaction score
1,901
  • Like
Reactions: Roo
Comment

Roo

Member
XFtoWP
Messages
9
Reaction score
1
Hi @Roo, apologies for the delayed response and that is not the norm around here—just an unusual month offline

I went to your site and got this message when I tried to visit the API:




Ensure you do not have a folder in your XF directory named /api/.
Hi,

We seem to be up and running now. Thanks!
 
Comment
Top